React Native

This page contains an overview of all relevant changes made to the Amity UIKit modules and the latest version releases

Fixes:

  • Fixed the sorting of items to be alphabetical instead of by creation date.

  • Fixed the poll end date display, where polls ending in 2 days were incorrectly shown as ending in 1 day.

  • Fixed the issue where the 'Create a Community' button was cut off.

  • Fixed an issue where closed communities would still appear as open when revisited.

  • Fixed the color of the three dots in community member details in dark mode.

  • Applied dark theme to User Profile, User Profile Settings, Community Settings, and Poll Creation pages.

Compatibility

  • React >= v16

  • NodeJS >= v18

  • NPM >= v6

  • yarn >= v1.22.15

  • Minimum iOS Target = 13.4

  • Kotlin = 1.8.0

  • minSdkVersion android = 21

Fixes:

  • Fixed an issue where the StoryCircle blinked upon loading the community home page.

  • Fixed an issue that allowed posting in a community by non-members.

  • Fixed the visibility of the Cancel button in the Edit community profile section, which was previously cut off on smaller screens.

  • Fixed an issue where the Save button could not be clicked when trying to add or edit a community profile picture.

Compatibility

  • React >= v16

  • NodeJS >= v18

  • NPM >= v6

  • yarn >= v1.22.15

  • Minimum iOS Target = 13.4

  • Kotlin = 1.8.0

  • minSdkVersion android = 21


New Features:

Amity UIKit 4.0 Framework

  • Introduction of UIKit 4.0 beta: A comprehensive overhaul of the UIKit, offering enhanced performance, scalability, and ease of use.

  • Modernized UI/UX: Adoption of the latest design trends and standards, ensuring a more intuitive and user-friendly experience.

Story Feature

  • Dynamic Story Creation: Users can now create interactive and engaging stories, similar to popular social media platforms.

  • Rich Media Support: Enhanced support for images, and videos within stories.

For further information please visit UIKit V4 (beta) and Story.

As of now, the enhanced customization options and the design updates in Amity UIKit 4.0 are exclusively available for the Story feature. These advancements provide a glimpse into the future possibilities of the toolkit. We plan to extend these capabilities to other features in future releases, continually expanding the versatility and applicability of the UIKit.

Breaking changes:

  • Set minimum version of peer-dependencies.

Compatibility

  • React >= v16

  • NodeJS >= v18

  • NPM >= v6

  • yarn >= v1.22.15

  • Minimum iOS Target = 13.4

  • Kotlin = 1.8.0

  • minSdkVersion android = 21

Last updated